首页 > 易语言 > 【易模块】将编辑框变成热键框.纯代码判断.

【易模块】将编辑框变成热键框.纯代码判断.

模块名称:编辑框转热键框
作者:吣碎De人
版本:1.0

可以将编辑框转变成热键框,使用方法简单,支持所有有按下某键的组件.
非API,纯判断.
使用方法:将代码置入 组件_按下某键 事件下.
@备注:
作者博客:http://www.qs5.org

------------------------------

.版本 2

.子程序 _取键名, 文本型, 公开, 将键代码转成键名
.参数 键代码, 整数型

.子程序 _转换键代码, 文本型, 公开, 将键代码与功能键转换成对应键名,实现热键框功能,成功返回对应文本,失败返回空文本.
.参数 键代码, 整数型, , 直接将事件的"键代码"传过来即可.
.参数 功能键状态, 整数型, , 直接将事件的"功能键状态"传过来即可.
.参数 自动添加功能键, 整数型, 可空, 将自动添加的功能键值发来,可以是多个值相加
.参数 屏蔽功能键, 整数型, 可空, 将过滤掉对应功能键键值,如果同时存在于自动添加功能键,则自动添加功能键优先.
.参数 禁用普通键, 整数型, 可空 数组, 接收需要过滤的普通键的键值数组数据,不建议使用,增加负荷.(暂不支持)

下载地址:本站下载|既得|115网盘|官方网站

上一篇: WP博客同时使用WP-Mail-SMTP与使用留言回复通知插件(Comment Reply Notification)无法发送邮件的解决办法.

下一篇: 【公告】有偿制作普通易语言程序,按键精灵脚本.

最近回复

标签